码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1856 并查集

时间:2014-07-11 10:41:03      阅读:241      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   java   strong   os   

http://acm.hdu.edu.cn/showproblem.php?pid=1856

 

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 13672    Accepted Submission(s): 5008


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang‘s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

 

Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
 

 

Sample Output
4
2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 
 
 
 
 
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;

#define Maxint 10000000
int user[Maxint],rank[Maxint];

void Markset(int size)
{
    for(int i=1;i<=Maxint;i++)
    {
        user[i]=i;
        rank[i]=1;
    }
}

int find(int x)
{
    if(x!=user[x])
    {
        user[x]=find(user[x]);
    }
    return user[x];
}

void Union(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x == y)return ;
    if(x!=y)
    {
        user[x]=y;
        rank[y]+=rank[x];
    }
}

int main()
{
    int n,m,i,j,a,b;
    while(scanf("%d",&n)!=EOF)
    {
        if(n ==0){printf("1\n"); continue;}
        Markset(n);
        int max=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            if(a>max)
                max=a;
            if(b>max)
                max=b;
            Union(a,b);
        }

        int Max=0;
        for(i=1;i<=max;i++)
        {
            if(rank[i]>Max)
            Max=rank[i];
        }
        printf("%d\n",Max);
    }
    return 0;
}

  

 
 
 
 

hdu 1856 并查集,布布扣,bubuko.com

hdu 1856 并查集

标签:des   blog   http   java   strong   os   

原文地址:http://www.cnblogs.com/ccccnzb/p/3834146.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!