码迷,mamicode.com
首页 > 其他好文 > 详细

Hie with the Pie poj3311

时间:2015-08-03 14:30:03      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:

Description
The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input
Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output
For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input
3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0
Sample Output
8

(1)题意:一个送外卖的人,要将外卖全部送去所有地点再回到店离,求最短路。
(2)解法:首先用floyd求出最短路,然后再进行DP或者搜索(数据并不大)就行了。

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int n;
int d[20][20];
int visit[20];
int ans;

void DFS(int now,int c,int time)  //搜索now个地方,现在在i点,总时间
{
    if(now==n+1)    //n+1个点只需走n次
    {
        ans=min(ans,time+d[c][1]); //搜到最后一项,+在回到点1
        return ;
    }
    int i;
    for(i=2;i<=n+1;i++)
    {
        if(visit[i]==1) continue;
        visit[i]=1;
        DFS(now+1,i,time+d[c][i]);
        visit[i]=0;
    }
}
int main()
{
    while(scanf("%d",&n),n!=0)
    {
        int i,j,k;

        for(i=1;i<=n+1;i++)
        {
            for(j=1;j<=n+1;j++)
                scanf("%d",&d[i][j]);
        }

        for(k=1;k<=n+1;k++)
        {
            for(i=1;i<=n+1;i++)
            {
                for(j=1;j<=n+1;j++)
                    d[i][j]=min(d[i][j],d[i][k]+d[k][j]);  //floyd-warshall任意两点间的最短路
            }
        }
        memset(visit,0,sizeof(visit));
        visit[1]=1;
        ans=100000000;
        DFS(1,1,0);
        printf("%d\n",ans);

    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Hie with the Pie poj3311

标签:

原文地址:http://blog.csdn.net/xtulollipop/article/details/47255713

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!