码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 题目2100 Seeding(DFS)

时间:2015-08-03 14:46:16      阅读:112      评论:0      收藏:0      [点我收藏+]

标签:

Seeding

Time Limit: 2 Seconds      Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. ‘S‘ is a square with stones, and ‘.‘ is a square without stones.

Input is terminated with two 0‘s. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO

水水~~

ac代码

#include<stdio.h>
#include<string.h>
int n,m,flag,ans;
char map[10][10];
int dx[4]={0,1,0,-1};
int dy[4]={1,0,-1,0};
int jud(int x,int y)
{
	if(x<0||x>=n)
		return 0;
	if(y<0||y>=m)
		return 0;
	if(map[x][y]=='S')
		return 0;
	return 1;
}
void dfs(int x,int y)
{
	int i;
	//vis[x][y]=1;
	if(ans==0)
	{
		flag=1;
		return;
	}
	if(flag)
		return;
	for(i=0;i<4;i++)
	{
		int tx=x+dx[i];
		int ty=y+dy[i];
		if(jud(tx,ty))
		{
			map[tx][ty]='S';
			ans--;
			dfs(tx,ty);
			map[tx][ty]='.';
			ans++;
		}
	}
}
int main()
{
//	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF,n||m)
	{
		int i,j;
		ans=n*m;
		flag=0;
		for(i=0;i<n;i++)
		{
			scanf("%s",map[i]);
			for(j=0;j<m;j++)
			{
				if(map[i][j]=='S')
					ans--;
			}
		}
		ans--;
		map[0][0]='S';
		dfs(0,0);
		if(flag)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

ZOJ 题目2100 Seeding(DFS)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/47253955

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!