码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5339

时间:2015-08-03 19:08:19      阅读:83      评论:0      收藏:0      [点我收藏+]

标签:

Untitled

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 828    Accepted Submission(s): 460

Problem Description
There is an integer a and n integers b1,…,bn. After selecting some numbers from b1,…,bn in any order, say c1,…,cr, we want to make sure that a mod c1 mod c2 mod… mod cr=0 (i.e., a will become the remainder divided by ci each time, and at the end, we want a to become 0). Please determine the minimum value of r. If the goal cannot be achieved, print ?1 instead.
 
Input
The first line contains one integer T≤5, which represents the number of testcases. 
For each testcase, there are two lines:
1. The first line contains two integers n and a (1≤n≤20,1≤a≤106).
2. The second line contains n integers b1,…,bn (?1≤i≤n,1≤bi≤106).
 
Output
Print T answers in T lines.
 
Sample Input
2
2 9
2 7
2 9
6 7
 
Sample Output
2

-1

//题意:给你n个数 在n个数中调出最少的元素使得 m%a1%a2%a3=0不存在就输出-1

//搜索

#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
using namespace std;
int m,n;
int d[1000010];
bool vis[1000010];

struct Node
{
    int x,step;
};

int bfs(int x)
{
    queue<Node>q;
    Node a;
    a.x=x,a.step=0;
    q.push(a);
    while(!q.empty())
    {
        Node b=q.front();
        q.pop();
        vis[b.x]=1;
        if(b.x==0)return b.step;
        for(int i=n-1;i>=0;i--)
        {
            Node c=b;
            c.x=c.x%d[i];
            c.step++;
            if(!vis[c.x])
            {
                vis[c.x]=1;
                q.push(c);
            }
        }
    }
    return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(d,0,sizeof(d));
        memset(vis,0,sizeof(vis));
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&d[i]);
        }
            int cnt=bfs(m);
            if(cnt==0)
                printf("-1\n");
            else
                printf("%d\n",cnt);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5339

标签:

原文地址:http://blog.csdn.net/a73265/article/details/47260119

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!