码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-1506-Largest Rectangle in a Histogram【动态规划】

时间:2015-08-03 19:22:44      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14050 Accepted Submission(s): 4008


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
技术分享
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0

Sample Output
8 4000

Source

Recommend
LL | We have carefully selected several similar problems for you:1058 2870 2830 2159 1421

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
__int64 a[100010];
__int64 l[100010],r[100010];
int main(){
    int n;
	while(scanf("%d",&n),n)	{
		for(int i=1;i<=n;++i){
			scanf("%I64d",&a[i]);
		}
		a[0]=a[n+1]=-1;l[0]=0,r[n+1]=0;
		for(int i=1;i<=n;++i){
			l[i]=i;
			while(a[l[i]-1]>=a[i]){
				l[i]=l[l[i]-1];
			}
		}
		for(int i=n;i>=1;--i){
			r[i]=i;
			while(a[r[i]+1]>=a[i]){
				r[i]=r[r[i]+1];
			}	
		}
		__int64 maxn=0;
		for(int i=1;i<=n;++i)
		  maxn=max(maxn,(r[i]-l[i]+1)*a[i]);
		printf("%I64d\n",maxn);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj-1506-Largest Rectangle in a Histogram【动态规划】

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/47258311

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!