码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1198(并查集)

时间:2015-08-03 22:25:05      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7080    Accepted Submission(s): 3041


Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

技术分享

Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC
FJK
IHE

then the water pipes are distributed like 

技术分享

Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
 

 

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A‘ to ‘K‘, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
 

 

Output
For each test case, output in one line the least number of wellsprings needed.
 

 

Sample Input
2 2 DK HF 3 3 ADC FJK IHE -1 -1
 

 

Sample Output
2 3
#include <iostream>
#include <memory.h>
#include <stdio.h>
using namespace std;
char input[50][50];
int parent[2500];
bool vis[2500];
int ans,N,M;
int Init()
{
    for(int i=(N+1)*(M+1);i>=0;i--)
        parent[i]=i;
}
//将字母对应的图案按照上右下左的顺序是否有接口压缩成为二进制对应位是否有1,最高位代表上
int change(char ch)
{
    switch(ch)
    {
        case ‘A‘:return 9;
        case ‘B‘:return 12;
        case ‘C‘:return 3;
        case ‘D‘:return 6;
        case ‘E‘:return 10;
        case ‘F‘:return 5;
        case ‘G‘:return 13;
        case ‘H‘:return 11;
        case ‘I‘:return 7;
        case ‘J‘:return 14;
        case ‘K‘:return 15;
    }
}
//查找父节点的操作,并做路径压缩
int findP(int x)
{
    if(parent[x]==x)
        return x;
    else
    {
        parent[x]=findP(parent[x]);
        return parent[x];
    }
}
void Union(int x,int y)
{
    int xp=findP(x),yp=findP(y);
    parent[yp]=xp;
    return;
}
int main()
{
    freopen("in.in","r",stdin);
    while(~scanf("%d%d",&N,&M)&&N!=-1)
    {
        getchar();
        Init();
        for(int i=0;i<N;i++)
        {
            for(int j=0;j<M;j++)
            {
                scanf("%c",&input[i][j]);
                input[i][j]=change(input[i][j]);
                //查看这一点是否可以和上相邻联通
                if(i>0&&((input[i][j]>>3)&(input[i-1][j]>>1)&1))
                {
                    Union(i*M+j,(i-1)*M+j);
                }
                //查看这一点是否可以和左相邻联通
                if(j>0&&((input[i][j-1]>>2)&input[i][j]&1))
                {
                    Union(i*M+j,i*M+j-1);
                }
            }
            getchar();
        }
        ans=0;
        memset(vis,0,sizeof(vis));
        //检查本点父亲是否已被计算过,本点父亲没被计算过说明本点父亲代表的分量需要一个“源“,并修改本点父亲为已经计算过
        for(int i=0;i<N;i++)
        {
            for(int j=0;j<M;j++)
            {
                if(!vis[findP(i*M+j)])
                {
                   vis[findP(i*M+j)]=true;
                   ans++;
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

  

hdu1198(并查集)

标签:

原文地址:http://www.cnblogs.com/modengdubai/p/4700531.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!