码迷,mamicode.com
首页 > 其他好文 > 详细

九度oj 二叉树遍历 题目1184

时间:2015-08-03 22:48:38      阅读:221      评论:0      收藏:0      [点我收藏+]

标签:


题目描述:

编一个程序,读入用户输入的一串先序遍历字符串,根据此字符串建立一个二叉树(以指针方式存储)。
例如如下的先序遍历字符串:
ABC##DE#G##F###
其中“#”表示的是空格,空格字符代表空树。建立起此二叉树以后,再对二叉树进行中序遍历,输出遍历结果。

输入:

输入包括1行字符串,长度不超过100。

输出:

可能有多组测试数据,对于每组数据,
输出将输入字符串建立二叉树后中序遍历的序列,每个字符后面都有一个空格。
每个输出结果占一行。

样例输入:
abc##de#g##f###
样例输出:
c b e g d f a 
来源:
2002年华中科技大学计算机研究生机试真题
#include<string.h>
#include<stdio.h>
#include<stdlib.h>
#include<malloc.h>
typedef struct node
{
 char m;
 struct node *lchild;
 struct node *rchild;
}*linklist;
void chu(linklist *head)
{
 (*head)=NULL;
}
void xtree(linklist *head)
{
 char x;
 scanf("%c",&x);
 if(x==‘#‘) (*head)=NULL;
 else
 {
  (*head)=(linklist)malloc(sizeof(struct node));
  (*head)->m=x;
  xtree(&((*head)->lchild));
  xtree(&((*head)->rchild));
 }
}
void ztree(linklist head)
{
 if(head)
 {
  ztree(head->lchild);
  printf("%c ",head->m);
  ztree(head->rchild);
 }
}
int main()
{
 char s[100];
 int n;
 linklist head;
 chu(&head);
 scanf("%d",&n);
 while(n--)
 {
  xtree(&head);
  ztree(head);
 }
 return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

九度oj 二叉树遍历 题目1184

标签:

原文地址:http://blog.csdn.net/yueloveme/article/details/47262639

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!