码迷,mamicode.com
首页 > 其他好文 > 详细

Oil Deposits

时间:2015-08-03 22:50:42      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18183    Accepted Submission(s): 10480


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
0 1 2 2
唉,刚开始用字符输出,不知道怎么了输出时结果总是少一行,后来改为字符串输出,才符合要求。
#include<stdio.h>
#include<cstring>
#include<algorithm>
using namespace std;
char s[105][105];
int a,b,r,ans,q;
void f(int x,int y)
{
	
	if(x<0||x>a-1||y<0||y>b-1)
	return ;
	if(s[x][y]=='*')
	return ;
		//ans++;
	s[x][y]='*';
	f(x,y+1);
	f(x,y-1);
	f(x+1,y);
	f(x-1,y);
	f(x-1,y-1);
	f(x+1,y+1);
	f(x+1,y-1);
	f(x-1,y+1);
}
int main()
{
     int k,x,y,h,e;
	while(scanf("%d%d",&a,&b),a|b)
	{	
		getchar();
		r=0;k=0;//;
		int max;
		q=0;
		int i,j;
		//memset(s,0,sizeof(s));
		for(i=0;i<a;i++)
		{
			scanf("%s",s[i]);
     	}
     	for(i=0;i<a;i++)
			for(j=0;j<b;j++)
             if(s[i][j]=='@')
             {
             	q++;
             	f(i,j);
              }		
		printf("%d\n",q);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Oil Deposits

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/47262179

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!