码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1312(Red and Black)

时间:2015-08-03 22:54:18      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:hdu   1312   深搜   java   

点击打开杭电1312

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
45 59 6 13
import java.util.Scanner;


public class P1312 {
	public static int n,m,count;
	public static int[][] dir={{1, 0}, {0, -1}, { -1, 0}, {0, 1}};//朝四个方向遍历
	public static char[][] map=new char[30][30];//地图
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			count=0;
			m=sc.nextInt();
			n=sc.nextInt();
			if(m==0&&n==0){
				break;
			}
			for(int i=0;i<n;i++){
				String s=sc.next();
				map[i]=s.toCharArray();
			}
			boolean sign=false;
			for(int i=0;i<n;i++){
				for(int j=0;j<m;j++){
					if(map[i][j]=='@'){//先找到@这点,然后将其作为起点朝四个方向递归遍历
						sign=true;//优化,因为只有一个@,所以只要进来,就不需要找循环找@了
						DFS(i,j);
					}
					if(sign){//优化
						break;
					}
				}
			}
			System.out.println(count+1);
		}
	}
	private static void DFS(int a, int b) {
		int x,y;
		for(int i=0;i<4;i++){
			x=a+dir[i][0];
			y=b+dir[i][1];
			if(x>=0&&y>=0&&x<n&&y<m&&map[x][y]=='.'){
				count++;
				map[x][y]='#';//直接把找到的'.' 变为#,这样就避免visit标记地图了
				DFS(x,y);
			}
		}
	}

}




版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu1312(Red and Black)

标签:hdu   1312   深搜   java   

原文地址:http://blog.csdn.net/u011479875/article/details/47261829

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!