码迷,mamicode.com
首页 > 其他好文 > 详细

Let the Balloon Rise

时间:2015-08-04 13:39:37      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:


Let the Balloon Rise
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 6

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges‘ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink
#include<iostream>
#include<string>
#include<stdio.h>
#include<map>
using namespace std;
int main()
{
map<string,int> m;
//map<string,int>::iterator it;
int Max;
string s;
int n;
int i,j;
while(scanf("%d",&n),n)
{
Max=-1;
for(i=0;i<n;i++)
{
cin>>s;
m[s]++;
}
for(map<string,int>::iterator it=m.begin();it!=m.end();it++)
if((*it).second>Max)
{ s=(*it).first; Max=(*it).second;}
cout<<s<<endl;
m.clear();
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Let the Balloon Rise

标签:

原文地址:http://blog.csdn.net/bailuweishuang520/article/details/47274149

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!