标签:
Osu!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1263 Accepted Submission(s): 660
Special Judge
Problem Description
Osu! is a very popular music game. Basically, it is a game about clicking. Some points will appear on the screen at some time, and you have to click them at a correct time.
Now, you want to write an algorithm to estimate how diffecult a game is.
To simplify the things, in a game consisting of N points, point i will occur at time t
i at place (x
i, y
i), and you should click it exactly at t
i at (x
i, y
i). That means you should move your cursor
from point i to point i+1. This movement is called a jump, and the difficulty of a jump is just the distance between point i and point i+1 divided by the time between t
i and t
i+1. And the difficulty of a game is simply the difficulty
of the most difficult jump in the game.
Now, given a description of a game, please calculate its difficulty.
Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.
For each test case, the first line contains an integer N (2 ≤ N ≤ 1000) denoting the number of the points in the game. Then N lines follow, the i-th line consisting of 3 space-separated integers, ti(0 ≤ ti < ti+1 ≤ 106),
xi, and yi (0 ≤ xi, yi ≤ 106) as mentioned above.
Output
For each test case, output the answer in one line.
Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
Sample Input
2
5
2 1 9
3 7 2
5 9 0
6 6 3
7 6 0
10
11 35 67
23 2 29
29 58 22
30 67 69
36 56 93
62 42 11
67 73 29
68 19 21
72 37 84
82 24 98
Sample Output
9.2195444573
54.5893762558
Hint
In memory of the best osu! player ever Cookiezi.
Source
Recommend
liuyiding | We have carefully selected several similar problems for you:
5342 5341 5340 5339 5338
水。
就是求最大的困难点。困难点就是两个点之间的距离除以两个点出现的时间差
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
struct Point{
double t,x,y;
}point[1000010];
double dist(Point a,Point b)
{
return (sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)))/(b.t-a.t);
}
int main()
{
int t;
scanf("%d",&t);
while(t--){
int M;
scanf("%d",&M);
double res;
Point temp;
Point x1,x2;
for(int i=0;i<2;i++){
scanf("%lf%lf%lf",&point[i].t,&point[i].x,&point[i].y);
}
res=dist(point[0],point[1]);
temp.x=point[1].x;temp.y=point[1].y;temp.t=point[1].t;
for(int i=2;i<M;i++){
scanf("%lf%lf%lf",&point[i].t,&point[i].x,&point[i].y);
res=max(res,dist(temp,point[i]));
temp.x=point[i].x;temp.y=point[i].y;temp.t=point[i].t;
}
printf("%.10lf\n",res);
}
return 0;
}
HDOJ Osu! 5078【2014鞍山区域赛I题-水】
标签:
原文地址:http://blog.csdn.net/ydd97/article/details/47276205