码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ Galaxy 5073【2014年鞍山区域赛D题-方差】

时间:2015-08-04 15:46:24      阅读:102      评论:0      收藏:0      [点我收藏+]

标签:

Galaxy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2800    Accepted Submission(s): 684
Special Judge


Problem Description
Good news for us: to release the financial pressure, the government started selling galaxies and we can buy them from now on! The first one who bought a galaxy was Tianming Yun and he gave it to Xin Cheng as a present.

技术分享

To be fashionable, DRD also bought himself a galaxy. He named it Rho Galaxy. There are n stars in Rho Galaxy, and they have the same weight, namely one unit weight, and a negligible volume. They initially lie in a line rotating around their center of mass.

Everything runs well except one thing. DRD thinks that the galaxy rotates too slow. As we know, to increase the angular speed with the same angular momentum, we have to decrease the moment of inertia.

The moment of inertia I of a set of n stars can be calculated with the formula

技术分享

where wi is the weight of star i, di is the distance form star i to the mass of center.

As DRD’s friend, ATM, who bought M78 Galaxy, wants to help him. ATM creates some black holes and white holes so that he can transport stars in a negligible time. After transportation, the n stars will also rotate around their new center of mass. Due to financial pressure, ATM can only transport at most k stars. Since volumes of the stars are negligible, two or more stars can be transported to the same position.

Now, you are supposed to calculate the minimum moment of inertia after transportation.
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers, n(1 ≤ n ≤ 50000) and k(0 ≤ k ≤ n), as mentioned above. The next line contains n integers representing the positions of the stars. The absolute values of positions will be no more than 50000.
 

Output
For each test case, output one real number in one line representing the minimum moment of inertia. Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
 

Sample Input
2 3 2 -1 0 1 4 2 -2 -1 1 2
 

Sample Output
0 0.5
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  5342 5341 5340 5339 5338 
 

  求方差~

讲解:点击打开链接

输入格式后面的0不用去掉,题目没要求

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 50000+10

using namespace std;

double s[maxn];

int main()
{
	int t;
	scanf("%d",&t);
	int n,k;
	while(t--){
		scanf("%d%d",&n,&k);
		for(int i=0;i<n;i++){
			scanf("%lf",&s[i]);
		}
		sort(s,s+n);
		int cnt=n-k;
		if(n==k){
			printf("0\n");
			continue;
		}
		double sum1=0;
		double sum2=0;
		for(int i=0;i<cnt;i++){
			sum1+=s[i];
			sum2+=s[i]*s[i];
		}
		double ans=sum2-(sum1*sum1)/cnt;
		for(int i=cnt;i<n;i++){
			sum1+=s[i];
			sum2+=s[i]*s[i];
			sum1-=s[i-cnt];
			sum2-=s[i-cnt]*s[i-cnt];
			ans=min(ans,(sum2-(sum1*sum1/(n-k))));
		}
		printf("%.10lf\n",ans);
	}
	return 0;
}


版权声明:本文为博主原创文章,转载请注明出处。

HDOJ Galaxy 5073【2014年鞍山区域赛D题-方差】

标签:

原文地址:http://blog.csdn.net/ydd97/article/details/47276071

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!