码迷,mamicode.com
首页 > 其他好文 > 详细

Eddy's research I

时间:2015-08-04 15:50:54      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:

Eddy‘s research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7601    Accepted Submission(s): 4618


Problem Description
Eddy‘s interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can‘t write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

 

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
 

Output
You have to print a line in the output for each entry with the answer to the previous question.
 

Sample Input
11 9412
 

Sample Output
11 2*2*13*181
 

Author
eddy
这个方法不错。由小到大~参考博客:http://blog.csdn.net/lishuhuakai/article/details/8184207
#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
using namespace std;
bool a[65535];
void isprime()
{
    memset(a,true,sizeof(a));
    int i,j;
    a[0]=a[1]=false;
    for(i=2;i<sqrt(65535);i++)
    {
        if(a[i])
        {
            for(j=i*i;j<65535;j+=i)
            {
                a[j]=false;
            }
        }
    }
}
int main()
{
    int x,flag,i,max;
    isprime();
    while(scanf("%d",&x)!=EOF)
    {
        max=x;
        flag=1;
        for(i=2;i<=max;i++)
        {
            while(a[i] && x%i==0)
            {
                   if(flag)
                    {
                     cout<<i;
                       flag=0;
                    } 
                    else
                    {
                        cout<<"*"<<i;
                    }
                x=x/i;
                if(x==1) 
                {cout<<endl;break;
                 }
            }
            
        }
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Eddy's research I

标签:

原文地址:http://blog.csdn.net/zuguodexiaoguoabc/article/details/47275939

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!