码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3620--Avoid The Lakes【DFS】

时间:2015-08-04 17:19:36      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:

Avoid The Lakes
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6775   Accepted: 3620

Description

Farmer John‘s farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

题意:第一行输入 n , m ,k 。代表有个 n * m 大小的地区, k 代表有k个水坑,接下来的k行代表k个水坑的坐标,

一个水坑可以和它上下左右的水坑组成一个大水坑,问大水坑最多有多少个小水坑组成。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;

int dir[4][2] = {1, 0, -1, 0, 0, -1, 0, 1};
int map[110][110];
int vis[110][110];
int n, m, k, ans;

bool check(int x, int y){
    if(x < 1 || x > n || y < 1 || y > m)
        return 0;
    if(map[x][y] == 0)
        return 0;
    if(vis[x][y] == 1)
        return 0;
    return 1;
}

void dfs(int x,int y){
    ans++;
    vis[x][y] = 1;
    for(int i = 0; i < 4; ++i){
        int fx = x + dir[i][0];
        int fy = y + dir[i][1];
        if(check(fx, fy))
            dfs(fx, fy);
    }
}

int main (){
    while(scanf("%d%d%d", &n, &m, &k) != EOF){
        memset(map, 0, sizeof(map));
        while(k--){
            int x, y;
            scanf("%d%d", &x, &y);
            map[x][y] = 1;
        }
        memset(vis, 0, sizeof(vis));
        int sum = 0;
        for(int i = 1;i <= n; ++i)
        for(int j = 1; j <= m; ++j){
            ans = 0;
            if(map[i][j]){
                dfs(i, j);
                sum = max(sum, ans);
            }
        }
        printf("%d\n", sum);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 3620--Avoid The Lakes【DFS】

标签:

原文地址:http://blog.csdn.net/hpuhjh/article/details/47278083

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!