码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ Seeding 2100【简单深搜】

时间:2015-08-04 19:15:52      阅读:96      评论:0      收藏:0      [点我收藏+]

标签:

Seeding

Time Limit: 2 Seconds      Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. ‘S‘ is a square with stones, and ‘.‘ is a square without stones.

Input is terminated with two 0‘s. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO



Author: ZHANG, Zheng
Source: Zhejiang University Local Contest 2004

简单深搜

#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

bool used[10][10];
char Map[10][10];
int dx[4]={1,-1,0,0};
int dy[4]={0,0,-1,1};
int N,M;
int num;
int tot;
int flag;

void DFS(int x,int y)
{
	used[x][y]=true;
	if(tot==num) {
		flag=1;
		//printf("YES\n");
		return;// true;
	}
	for(int i=0;i<4;i++){
		int nx=x+dx[i];
		int ny=y+dy[i];
		if(Map[nx][ny]=='.'&&0<=nx&&nx<N&&0<=ny&&ny<M&&!used[nx][ny]){
			//used[nx][ny]=true;
			tot++;
			//printf("-->%d %d\n",nx,ny);
			DFS(nx,ny);
			//printf("<--%d %d\n",nx,ny);
			tot--;
			used[nx][ny]=false;
			//return;
		}
	}
	//printf("NO\n");
	return;// false;
}

int main()
{
	while(scanf("%d%d",&N,&M),N!=0||M!=0){
		for(int i=0;i<N;i++){
			scanf("%s",Map[i]);
		}
		num=0;
		tot=1;
		flag=0;
		for(int i=0;i<N;i++){
			for(int j=0;j<M;j++){
				if(Map[i][j]=='.')
				num++;
			}
		}
		
		memset(used,false,sizeof(used));
		DFS(0,0);
		//printf("%d %d\n",num,tot);
		if(!flag)printf("NO\n");
		else printf("YES\n");
	}
	return 0;
}


版权声明:本文为博主原创文章,转载请注明出处。

ZOJ Seeding 2100【简单深搜】

标签:

原文地址:http://blog.csdn.net/ydd97/article/details/47280419

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!