码迷,mamicode.com
首页 > 其他好文 > 详细

1068Parencodings栈

时间:2015-08-04 19:23:43      阅读:108      评论:0      收藏:0      [点我收藏+]

标签:

Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 23040   Accepted: 13501

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
题意:一个括号表达式可以按照如下的规则表示,就是每个右括号之前的左括号数。
比如(((()()()))),每个右括号之前的左括号数序列为P=4 5 6 6 6 6,而每个右括号所在的括号内包含的括号数为W=1 1 1 4 5 6.
现在给定P,输出W。
我的思路:先根据P还原整个括号表达式,存在数组中利用栈求解


#include<iostream>
#include<cstdio>

using namespace std;

int main()
{
    int T,n;
    while(cin>>T)
    {
        while(T--)
        {
            cin>>n;
            int a[1000];
            for(int i=0; i<n; i++)
                cin>>a[i];
          
            for(int i=n-1; i>=1; i--)
                a[i]-=a[i-1];
            int num=0;
            int s[10001];
            for(int i=0; i<n; i++) //转化格式
            {
                for(int j=0; j<a[i]; j++)
                {
                    s[num++]=0;
                }
                s[num++]=1;
            }

            int ss[10001],top=0;
            for(int i=0; i<num; i++)
            {
                ss[++top]=s[i];
                if(s[i]==1)
                {
                    int k=top;
                    int flag=0;
                    while(ss[k]!=0) //统计包含的括号数
                    {
                        flag+=1;
                        k--;
                    }
                    ss[top]=flag;
                    for(int i=k; i<=top; i++) //每匹配一个括号则消除一个左括号的位置
                    {
                        ss[i]=ss[i+1];
                    }
                   top--;
                }
            }
            int kk=1;
            for(int i=1; i<=top; i++)
            {
                if(kk==1)    kk=0;
                else      <span id="transmark"></span>cout<<" ";
                cout<<ss[i];
            }
            cout<<endl;
        }
    }
}



    
        

版权声明:本文为博主原创文章,未经博主允许不得转载。

1068Parencodings栈

标签:

原文地址:http://blog.csdn.net/became_a_wolf/article/details/47279859

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!