码迷,mamicode.com
首页 > 其他好文 > 详细

FZU 1650 1752 a^b mod

时间:2015-08-04 21:09:46      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:

Problem 1752 A^B mod C

Accept: 837    Submit: 3615
Time Limit: 1000 mSec    Memory Limit : 32768 KB

技术分享 Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

技术分享 Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

技术分享 Output

For each testcase, output an integer, denotes the result of A^B mod C.

技术分享 Sample Input

3 2 42 10 1000

技术分享 Sample Output

124

技术分享 Source

FZU 2009 Summer Training IV--Number Theory

题解:

大数据处理,次方用乘法,乘法用加法,保证不爆。

#include<stdio.h>
#define ll unsigned __int64
ll mul(ll a,ll b,ll c)
{
	ll tmp=a%c,tre=0;
	while(b)
	{
		if(b&1)
			if((tre+=tmp)>=c)
			   tre-=c; 
        if((tmp<<=1)>=c)
            tmp-=c;
        b>>=1;
	}
	return tre;
}
ll mod(ll a,ll b,ll c)
{
	ll y=1;
	a=a%c;
	while(b)
	{
		if(b&1)
		    y=mul(y,a,c);
        a=mul(a,a,c);
        b>>=1;
	}
	return y;
}
int main()
{
	ll a,b,c;
	while(~scanf("%I64u%I64u%I64u",&a,&b,&c))
	{
		printf("%I64u\n",mod(a,b,c));
	}
	return 0;
} 




版权声明:本文为博主原创文章,随便转载。

FZU 1650 1752 a^b mod

标签:

原文地址:http://blog.csdn.net/luwhere/article/details/47281389

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!