码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1505

时间:2015-08-04 21:12:15      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:

Description

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so calledscribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.


Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered 技术分享) that may have different number of pages ( 技术分享) and you want to make one copy of each of them. Your task is to divide these books among k scribes, 技术分享. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 技术分享 such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input 

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, 技术分享. At the second line, there are integers 技术分享 separated by spaces. All these values are positive and less than 10000000.

Output 

For each case, print exactly one line. The line must contain the input succession 技术分享 divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/‘) to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.


If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input 

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

Sample Output 

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100



Miguel A. Revilla
2000-02-15
题意:把m个连续的序列分成连续的k个子序列,设第i个连续的子序列的和为S(i),你的程序要尽量让最大的连续的子序列和S(i)最大值最小。输出用‘/‘隔开来,如果有多种方案,让后面的数的和尽量最大。
思路:
用一般的方法能够解出来,但是由于时间限制,会超时,因此,我们必须优化算法,可以参考算法竞赛与入门经典(刘汝佳)中的P228 二分查找,找出那个连续的最大和的最小值。然后按要求输出即可。
代码:
#include<cstdio>
#include<cstring>
using namespace std;
int book[505];
bool flag[505];
int m,k;
int cnt;
int copy(long long x)
{
    cnt=1;
    long long sum=0;
    memset(flag,false,sizeof(flag));
    for(int i=m-1;i>=0;i--)
    {
        sum+=book[i];
        if(sum>x)
        {
            cnt++;
            sum=book[i];
            flag[i]=true;
        }

    }
    return cnt;
}
void print()
{
    printf("%d",book[0]);
    for(int i=1;i<m;i++)
    {
        if(flag[i-1])   printf(" /");
        printf(" %d",book[i]);
    }
    printf("\n");

}
int main()
{
        int T;
        long long l,r;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&m,&k);
            l=r=0;
            for(int i=0;i<m;i++)
            {
                scanf("%d",&book[i]);
                if(book[i]>l)    l=book[i];
                r+=book[i];

            }
            long long mid;
            while(l<r)
            {
                mid=(l+r)/2;
                if(copy(mid)<=k)    r=mid;
                else l=mid+1;
            }
            int cnt=copy(r);
            for(int i=0;i<m&&cnt<k;i++)
            {
                if(!flag[i])   flag[i]=true,cnt++;


            }
          print();

        }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 1505

标签:

原文地址:http://blog.csdn.net/a1967919189/article/details/47281041

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!