码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1700 Points on Cycle(几何)(中等)

时间:2015-08-04 21:11:25      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:hdu   几何   

Points on Cycle

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1992    Accepted Submission(s): 721


Problem Description
There is a cycle with its center on the origin.
Now give you a point on the cycle, you are to find out the other two points on it, to maximize the sum of the distance between each other
you may assume that the radius of the cycle will not exceed 1000.
 


Input
There are T test cases, in each case there are 2 decimal number representing the coordinate of the given point.
 


Output
For each testcase you are supposed to output the coordinates of both of the unknow points by 3 decimal places of precision 
Alway output the lower one first(with a smaller Y-coordinate value), if they have the same Y value output the one with a smaller X. 

NOTE
when output, if the absolute difference between the coordinate values X1 and X2 is smaller than 0.0005, we assume they are equal.
 


Sample Input
2 1.500 2.000 563.585 1.251
 


Sample Output
0.982 -2.299 -2.482 0.299 -280.709 -488.704 -282.876 487.453


题意:
	一个以原点为中心的圆,告诉你圆上的一个点,求与另外的两个点组成的三角形的周长最长的两点作标。
 
思路:
	设P(x,y),一个方程是pow(x,2)+pow(y,2)=pow(r,2);另一个方程是根据向量知识,向量的夹角公式得到方程。
因为圆心角夹角为120度,已知一个向量(即一个点作标),所以COS(2PI/3)=a*b/|a|*|b|;(a,b为向量);
已知角和a向量,就可求b向量b(x,y).由方程组可求得(x,y);最后得到的是一元二次方程组,可得到两个解,即为两个点的作标。

代码:

#include <stdio.h>
#include <math.h>
#define PI 3.1415926

int main()
{
	double x,y,x1,y1,x2,y2,cosx,a,b,c,r,delta;
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf%lf",&x,&y);
		r=sqrt(x*x+y*y);
		a=r*r;
		b=r*r*y;
		c=r*r*r*r/4-x*x*r*r;
		delta=b*b-4*a*c;
		y1=(-1*b-sqrt(delta))/(2*a);
		y2=(-1*b+sqrt(delta))/(2*a);
		if(x==0)
		{
			x1=-sqrt(r*r-y1*y1);
			x2=sqrt(r*r-y2*y2);
		}
		else
		{
			x1=(-1*r*r/2-y*y1)/x;
			x2=(-1*r*r/2-y*y2)/x;
		}
		printf("%.3lf %.3lf %.3lf %.3lf/n",x1,y1,x2,y2);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 1700 Points on Cycle(几何)(中等)

标签:hdu   几何   

原文地址:http://blog.csdn.net/kaisa158/article/details/47281089

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!