码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 题目2734 Exchange Cards(DFS 去重OR 母函数)

时间:2015-08-04 23:03:11      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:

Exchange Cards

Time Limit: 2 Seconds      Memory Limit: 65536 KB

As a basketball fan, Mike is also fond of collecting basketball player cards. But as a student, he can not always get the money to buy new cards, so sometimes he will exchange with his friends for cards he likes. Of course, different cards have different value, and Mike must use cards he owns to get the new one. For example, to get a card of value 10$, he can use two 5$ cards or three 3$ cards plus one 1$ card, depending on the kinds of cards he have and the number of each kind of card. And Sometimes he will involve unfortunately in a bad condition that he has not got the exact value of the card he is looking for (fans always exchange cards for equivalent value).

Here comes the problem, given the card value he plans to get and the cards he has, Mike wants to fix how many ways he can get it. So it‘s you task to write a program to figure it out.

Input

The problem consists of multiple test cases, terminated by EOF. There‘s a blank line between two inputs.

The first line of each test case gives n, the value of the card Mike plans to get and m, the number of different kinds of cards Mike has. n will be an integer number between 1 and 1000. m will be an integer number between 1 and 10.

The next m lines give the information of different kinds of cards Mike have. Each line contains two integers, val and num, representing the value of this kind of card, and the number of this kind of card Mike have.

Note: different kinds of cards will have different value, each val and num will be an integer greater than zero.

Output

For each test case, output in one line the number of different ways Mike could exchange for the card he wants. You can be sure that the output will fall into an integer value.

Output a blank line between two test cases.

Sample Input

5 2
2 1
3 1

10 5
10 2
7 2
5 3
2 2
1 5

Sample Output

1

7

各种水

ac代码

DFS

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int n,m,k,ans;
int a[100010];
int cmp(const void *a,const void *b)
{
	return *(int *)b-*(int *)a;
}
void dfs(int pos,int sum)
{
	if(sum==n)
	{
		ans++;
		return;
	}
	for(int i=pos;i<k;i++)
	{
		if(a[i]+sum<=n)
		{
			dfs(i+1,sum+a[i]);
			while(i+1<k&&a[i]==a[i+1])
				i++;
		}
	}
}
int main()
{
	int flag=0;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i;
		if(flag)
			printf("\n");
		else
			flag=1;
		k=0;
		for(i=0;i<m;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			while(y--)
			{
				a[k++]=x;
			}
		}
		ans=0;
		qsort(a,k,sizeof(a[0]),cmp);
		dfs(0,0);
		printf("%d\n",ans);
	//	printf("\n");
	}
}

母函数做法
#include<stdio.h>
#include<string.h>
int c1[1010],c2[1010],b[15],a[15];
int main()
{
	int n,m,flag=0;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i,j,k;
		if(flag)
			printf("\n");
		else
			flag=1;
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&a[i],&b[i]);
		}
		for(i=0;i<=b[0]&&i*a[0]<=n;i++)
		{
			c1[i*a[0]]=1;
		}
		for(i=1;i<m;i++)
		{
			for(j=0;j<=n;j++)
			{
				for(k=0;k*a[i]+j<=n&&k<=b[i];k++)
				{
					c2[k*a[i]+j]+=c1[j];
				}
			}
			for(j=0;j<=n;j++)
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
		printf("%d\n",c1[n]);
	}
	return 0;
}



Author: DAI, Wenbin
Source: Zhejiang University Local Contest 2006

版权声明:本文为博主原创文章,未经博主允许不得转载。

ZOJ 题目2734 Exchange Cards(DFS 去重OR 母函数)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/47282921

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!