码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1258(Sum It Up)

时间:2015-08-04 23:06:55      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:杭电1258

点击打开hdu1258

Problem Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
 

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
 

Output

For each test case, first output a line containing ‘Sums of‘, the total, and a colon. Then output each sum, one per line; if there are no sums, output the line ‘NONE‘. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
 

Sample Input

4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
 


Sample Output

Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25
import java.util.Scanner;

public class P1258 {
	static int[] init=new int[100];//记录初始数据
	static int[] result=new int[100];//记录结果数据
	static int n,m,count;//count表示找到结果数据的个数
	static boolean flag=false;//判断是否找到满足条件的数据
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			n=sc.nextInt();
			m=sc.nextInt();
			if(n==0&&m==0){
				break;
			}
			for(int i=0;i<m;i++){
				init[i]=sc.nextInt();
			}
			flag=false;count=0;
			System.out.println("Sums of "+n+":");
			DFS(0,0);
			if(!flag){
				System.out.println("NONE");
			}
		}
	}
	private static void DFS(int sum, int k) {//sum表示目前找到数据的总和,k表示目前找到第几个数了
		if(sum>n){
			return ;
		}
		if(sum==n){//找到满足条件的数据,并输出结果
			flag=true;
			for(int i=0;i<count;i++){
				if(i==count-1){//控制输出格式
					System.out.println(result[i]);
				}else{
					System.out.print(result[i]+"+");
				}
			}
			return ;
		}
		int sign=-1;//大神们防止重复出现同一种数据的可能性,确实很叼,也就是在同一个位置,相等的数据只能出现一个,例如:4 等于第一个2加上后面两个1,
		//而第二个2加后面两个1结果也为4,这样就会重复同一结果(虽然是不同位置的数据组成的,但结果一样)。当然这种神操作也只能要求所给的数据是有序的,否则也没有什么卵用。
		for(int i=k;i<m;i++){
			if(sign!=init[i]){
				sign=init[i];
				result[count++]=init[i];
				DFS(sum+init[i],i+1);
				result[count--]=0;
			}
		}
		return ;
	}

}




版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu1258(Sum It Up)

标签:杭电1258

原文地址:http://blog.csdn.net/u011479875/article/details/47282429

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!