码迷,mamicode.com
首页 > 其他好文 > 详细

UVa 10020 - Minimal coverage(区间覆盖并贪心)

时间:2015-08-05 06:30:01      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:

Given several segments of line (int the X axis) with coordinates [Li, Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0, M].
Input
The first line is the number of test cases, followed by a blank line.
Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri”
(|Li|, |Ri| ≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair ‘0 0’.
Each test case will be separated by a single line.
Output
For each test case, in the first line of output your programm should print the minimal number of line
segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted
by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be
printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without
quotes).
Print a blank line between the outputs for two consecutive test cases.
Sample Input
2
1
-1 0
-5 -3
2 5
0 0
1
-1 0
0 1
0 0

Sample Output
0
1
0 1

 

题意:给定一个M,和一些区间[L,R]。。要选出几个区间能完全覆盖住[0,M]区间。要求数量最少。。如果不能覆盖输出0.

    思路:贪心的思想。。把区间按R从大到小排序。 然后遇到一个满足的[Li,Ri],就更新缩小区间。。直到完全覆盖。

    注意[L,R]只有满足L小于等于且R大于当前覆盖区间左端这个条件。才能选中。

 

#include <stdio.h>
#include <algorithm>
using namespace std;
int t;
int start,end,n,f;
struct qujian
{
    int start;
    int end;
};
qujian q[100005],p[100005];
int cmp (qujian a,qujian b)
{
    return a.end > b.end;
}
int main()
{
    scanf("%d", &t);
    while (t --)
    {
        n = 0;
        f = 0;
        start = 0;
        scanf("%d", &end);
        while (scanf("%d%d", &q[n].start, &q[n].end) && q[n].start + q[n].end)
        {
            n++;
        }
        sort(q,q+n,cmp);
        while(start<end)
        {
            int i;
            for (i=0;i<n;i++)
            {
                if (q[i].start <= start && q[i].end > start)
                {
                    start = q[i].end;   //更新区间
                    p[f] = q[i];
                    f++;
                    break;
                }
            }
            if (i==n) break;   //如果没有一个满足条件的区间,直接结束。
        }
        if(start<end) printf("0\n");
        else
        {
            printf("%d\n",f);
            for (int i=0;i<f;i++)
                printf("%d %d\n", p[i].start,p[i].end);
        }
        if (t) printf("\n");
    }
    return 0;
}

 

UVa 10020 - Minimal coverage(区间覆盖并贪心)

标签:

原文地址:http://www.cnblogs.com/hfc-xx/p/4703614.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!