码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5349 MZL's simple problem(优先队列)

时间:2015-08-05 16:32:43      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:

MZL‘s simple problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 776    Accepted Submission(s): 375


Problem Description
A simple problem
Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)
 

Input
The first line contains a number N (N106),representing the number of operations.
Next N line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than 109.
 

Output
For each operation 3,output a line representing the answer.
 

Sample Input
6 1 2 1 3 3 1 3 1 4 3
 

Sample Output
3 4
 

Source
 






#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<string>
#include<math.h>
#include<queue>
#include<stack>
#include<map>
#define INF 0x3f3f3f3f
#define eps 1e-6

using namespace std;

priority_queue<int, vector<int>, greater<int> > q;///从小到大排列

int n;
int main()
{
    while(scanf("%d",&n)!=EOF)
    {

        while(!q.empty())
        {
            q.pop();
        }
        int x,y;
        int flag  = 0;
        int maxx;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x);
            if(x == 1)
            {
                scanf("%d",&y);
                if(flag == 0)
                {
                    flag = 1;
                    maxx = y;
                }
                if(maxx < y)
                {
                    maxx = y;
                }
                q.push(y);
            }
            else if(x == 2)
            {
                if(q.size() > 0)
                {
                    int tt = q.top();
                    while(!q.empty() && q.top() == tt)
                    {
                        q.pop();
                    }
                }
                if(q.size() <= 0)
                {
                    flag = 0;
                }
            }
            else
            {
                if(q.size() > 0)
                {
                    printf("%d\n",maxx);
                }
                else
                {
                    printf("0\n");
                }
            }
        }
    }
    return 0;
}


版权声明:本文为博主原创文章,如有特殊需要请与博主联系 QQ : 793977586。

HDU 5349 MZL's simple problem(优先队列)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/47297537

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!