码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5344 MZL's xor(水题)

时间:2015-08-05 16:33:14      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:

MZL‘s xor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 456    Accepted Submission(s): 322


Problem Description
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1i,jn)
The xor of an array B is defined as B1 xor B2...xor Bn
 

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers:n,m,z,l
A1=0,Ai=(Ai?1?m+z) mod l
1m,z,l5?105,n=5?105
 

Output
For every test.print the answer.
 

Sample Input
2 3 5 5 7 6 8 8 9
 

Sample Output
14 16
 

Source



#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<string>
#include<math.h>
#include<queue>
#include<stack>
#include<map>
#define INF 0x3f3f3f3f
#define eps 1e-6

using namespace std;

int n,m,z,l;
int v[500015];
__int64 a[500015];
int b[500015];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d%d",&n,&m,&z,&l);
        memset(v,0,sizeof(v));
        v[0] = 1;
        a[0] = 1;
        int ph,pi;
        int i;
        int flag = 0;
        m = m%l;
        z = z%l;
        for(i=2;i<=n;i++)
        {
            a[i] = ((a[i-1]*m)+z)%l;
            //printf("a[%d] = %d\n",i,a[i]);
            v[a[i]]++;
        }
        int k = 1;
        for(int i=1;i<=n;i++)
        {
            if(v[a[i]]%2 == 1)
            {
                b[k] = a[i];
                v[a[i]] = 0;
                k++;
            }
        }
        __int64 sum = 0;
        __int64 sum1 = 0;
        for(int i=1;i<k;i++)
        {
            sum = b[i] + b[i];
            sum1^=sum;
        }
        printf("%I64d\n",sum1);
    }
    return 0;
}


版权声明:本文为博主原创文章,如有特殊需要请与博主联系 QQ : 793977586。

HDU 5344 MZL's xor(水题)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/47297445

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!