码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-3579-Hello Kiki【中国剩余定理 & 除数不互质】

时间:2015-08-05 18:35:00      阅读:124      评论:0      收藏:0      [点我收藏+]

标签:

Hello Kiki

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2590 Accepted Submission(s): 945


Problem Description
One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki‘s father found her note and he wanted to know how much coins Kiki was counting.

Input
The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi

Output
For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.

Sample Input
2 2 14 57 5 56 5 19 54 40 24 80 11 2 36 20 76

Sample Output
Case 1: 341 Case 2: 5996

Author
digiter (Special Thanks echo)

Source

Recommend
zhouzeyong | We have carefully selected several similar problems for you: 3573 3574 3575 3576 3577

#include<stdio.h>
int M[10],A[10];
int n;
void EXGCD(int a,int b,int &x,int &y,int &c){
	if(b==0){
		x=1;
		y=0;
		c=a;
		return;
	}
	EXGCD(b,a%b,x,y,c);
	int temp=x;
	x=y;
	y=temp-a/b*y;
}
int China_2(int M[],int B[]){
	int a1=M[0],b1=B[0];
	int ok=0,d,x,y,c,i;
	for(i=1;i<n;++i){
		if(ok) continue;
		EXGCD(a1,M[i],x,y,c);
		d=B[i]-b1;
		if(d%c){
			ok=1;
			continue;
		}
		int q=M[i]/c;
		x=(x*d/c%q+q)%q;
		b1=a1*x+b1;
		a1=a1*M[i]/c;  // a1 与 M[i] 的最小公倍数 
	} 
	if(ok) return -1;
	else return b1?b1:b1+a1;
}
int main(){
	int t,ncas=0;
	scanf("%d",&t);
	while(t--){
		ncas++;
		int i;
		scanf("%d",&n);
		for(i=0;i<n;++i){
			scanf("%d",&M[i]);
		}
		for(i=0;i<n;++i){
			scanf("%d",&A[i]);
		}
	    printf("Case %d: %d\n",ncas,China_2(M,A));
	}
	return 0;
}

此题陷阱:不能输出0
如测试数据: 对于 2
                                  3  4
                                  0  0
----->>应该输出12

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj-3579-Hello Kiki【中国剩余定理 & 除数不互质】

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/47299027

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!