码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1552 Doubles 水

时间:2015-08-05 20:26:08      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:c++   dp   poj   编程   

Doubles

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 20106   Accepted: 11667

Description

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input

The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

Output

The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output

3
2
0

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main(){
    int a[17];
    memset(a,0,sizeof(a));
    int i,j,count,t,n;
    cin>>a[0];
    while(a[0]!=-1){
        n=1;
        while(1){
            cin>>a[n];
            if(a[n]==0)break;
            n++;
        }
        for(count=0,i=0;i<n-1;++i){
            for(j=i+1;j<n;j++){
                if(a[i]*2==a[j]||a[j]*2==a[i])count++;
            }
        }
        cout<<count<<'\12';
        cin>>a[0];
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 1552 Doubles 水

标签:c++   dp   poj   编程   

原文地址:http://blog.csdn.net/zp___waj/article/details/47302161

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!