码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-1299-Diophantus of Alexandria【判断素因子个数+组合数】

时间:2015-08-05 22:18:33      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:

Diophantus of Alexandria

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2853 Accepted Submission(s): 1099


Problem Description
Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat‘s last theorem) was found only recently by Andrew Wiles.

Consider the following diophantine equation:

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)


Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions:

1 / 5 + 1 / 20 = 1 / 4
1 / 6 + 1 / 12 = 1 / 4
1 / 8 + 1 / 8 = 1 / 4



Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?

Input
The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9).

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line.

Sample Input
2 4 1260

Sample Output
Scenario #1: 3 Scenario #2: 113

Source

Recommend
JGShining | We have carefully selected several similar problems for you: 1211 1215 1695 1787 2824

#include<stdio.h> 
#include<math.h>
int factor(int n){
	int sqrtn=int(sqrt(n))+1;
	int sum=1;
	for(int div=2;div<=sqrtn;++div){
		int c=0;
		while(n%div==0){
			n/=div;
			++c;
		}
		if(c)
		sum*=(2*c+1);
	}
	if(n>1) sum*=3;
	return sum;
}
int main(){
	int n,t,ncas=0;
	scanf("%d",&t);
	while(t--){
		ncas++;
		scanf("%d",&n);
	    int res=factor(n);
        printf("Scenario #%d:\n",ncas);
		printf("%d\n\n",(res+1)/2);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj-1299-Diophantus of Alexandria【判断素因子个数+组合数】

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/47304055

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!