标签:
DNA Sorting
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2231 Accepted Submission(s): 1096
Problem Description
One measure of ``unsortedness‘‘ in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC‘‘, this measure is 5, since D is greater than four letters to its right and E is
greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG‘‘ has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM‘‘ has 6 inversions (it is as unsorted as can be--exactly
the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness‘‘, from ``most sorted‘‘ to ``least sorted‘‘.
All the strings are of the same length.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted‘‘ to ``least sorted‘‘. If two or more strings are equally sorted, list them in the same order they are in the input file.
Sample Input
1
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
Source
题目意思:
DAABEC 的长为 5 ,D比它右边的4个都大 、E比它右边1个大,逆序即为长度。
输出按从长到短,如果长度一样,按出现顺序。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
char s[55];
int ch,len;
}p[111];
bool cmp( node a,node b)
{
if( a.len!=b.len )
return a.len < b.len ;
return a.ch < b.ch;
}
int main()
{
int n, m, t, i, j, k;
scanf("%d",&t);
while( t-- )
{
scanf("%d%d",&n,&m);
for( i = 0; i < m; i++ )
{
scanf("%s",p[i].s);
int sum=0;
for( j = 0 ;j < n ;j++)
{
for( k = j+1; k < n ;k++ )
{
if( p[i].s[j] > p[i].s[k] )
sum++;
}
}
p[i].len=sum;
p[i].ch=i;
}
sort( p, p+m ,cmp );
for( i = 0; i < m ;i++)
printf("%s\n",p[i].s);
if( t != 0) printf("\n");
}
return 0;
}
hdoj 1379 DNA Sorting
标签:
原文地址:http://blog.csdn.net/liu6886/article/details/47302757