码迷,mamicode.com
首页 > 其他好文 > 详细

HDU5344——数学题——MZL's xor

时间:2015-08-06 00:00:57      阅读:510      评论:0      收藏:0      [点我收藏+]

标签:

MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1i,jn)
The xor of an array B is defined as B1 xor B2...xor Bn

 


Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers:n,m,z,l
A1=0,Ai=(Ai1m+z) mod l
1m,z,l5105,n=5105
 


Output
For every test.print the answer.
 


Sample Input
2 3 5 5 7 6 8 8 9
 


Sample Output
14 16
 


Source

 

/*
根据式子可以推出公式为所有值×2的异或和
*/
/************************************************
Author        :powatr
Created Time  :2015-8-5 22:08:30
File Name     :b.cpp
************************************************/

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cmath>
#include <string>
#include <vector>
#include <queue>
#include <deque>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <bitset>
#include <cstdlib>
#include <ctime>
using namespace std;

#define lson l, mid, rt << 1
#define rson mid + 1, r, rt << 1 | 1
typedef long long ll;
const int MAX = 1e6 + 10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;

ll a[MAX];
int main(){
    int n, m, z, l;
    int T;
    scanf("%d", &T);
    while(T--){
    scanf("%d%d%d%d", &n, &m, &z, &l);
    a[1] = 0;
        for(int i = 2; i <= n; i++)
            a[i] = (a[i-1]*m + z)%l;
    ll sum = 0;
    for(int i = 1; i <= n; i++)
        sum ^= 1ll*(a[i] << 1);
  printf("%I64d\n", sum);
    }
  return 0;
}  

  

HDU5344——数学题——MZL's xor

标签:

原文地址:http://www.cnblogs.com/zero-begin/p/4705998.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!