码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2109 :Power of Cryptography

时间:2014-07-10 23:57:35      阅读:335      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   strong   width   

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 18258   Accepted: 9208

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
This problem involves the efficient computation of integer roots of numbers. 
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234

这题有多坑。。不想多说了。。开始被那101次方被吓尿了。。

还有坑爹的是我用G++提交就WA。。改C++就AC。。我真不知道怎么说才好。。


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>

using namespace std;

int main()
{
    double n, m;
    while(scanf("%lf%lf", &n, &m)!=EOF)
    {
        printf("%.0lf\n",  pow(m, 1/n));
    }

    return 0;
}

注:这才是正常的吧。。。

#include<stdio.h>
#define N 1100
int n,a[N],k[10];
char p[N];
void pown()
{
    int i,j,g,b[N];
    for(i=1;i<N;i++)a[i]=0;
    a[0]=1;
    for(g=0;g<n;g++){
        for(i=0;i<N;i++){
            b[i]=a[i];
            a[i]=0;
        }
        for(i=0;i<N;i++)
            for(j=0;j<10;j++)
                a[i+j]+=b[i]*k[j];
        for(i=0;i<N-1;i++){
            a[i+1]+=a[i]/10;
            a[i]%=10;
        }
    }
}
int main()
{
    int i,j,t;
    while(~scanf("%d%s",&n,p)){
        for(i=0;i<10;i++)k[i]=0;
        for(t=0;p[t];t++)a[t]=p[t]-48;
        for(j=t;t<N;t++)p[t]=0;
        j--;
        for(i=0,t=j;i<t,j>=0;i++,j--)p[j]=a[i];//倒置p
        for(i=0;i<N;i++)a[i]=0;
        for(i=9;i>=0;i--){// 从最高到个位依次确定
            for(k[i]=9;k[i]>0;k[i]--){ //第i位上的值从9到0依次尝试
                pown();//求k的n次方
                for(j=N-1;j>0;j--)
                    if(a[j]!=p[j])break;
                if(a[j]<=p[j])break;
                //如果a(即此时的k^n值)小于等于p那么k的第i位值为当前值
            }
        }
        for(i=9;i>0;i--)
            if(k[i])break;
        for(;i>=0;i--)printf("%d",k[i]);
        puts("");
    }
    return 0;
}



POJ 2109 :Power of Cryptography,布布扣,bubuko.com

POJ 2109 :Power of Cryptography

标签:des   style   http   color   strong   width   

原文地址:http://blog.csdn.net/u013487051/article/details/37602451

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!