码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5349

时间:2015-08-06 11:08:55      阅读:72      评论:0      收藏:0      [点我收藏+]

标签:

MZL‘s simple problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 931    Accepted Submission(s): 436

Problem Description
A simple problem
Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)
 
Input
The first line contains a number N (N≤106),representing the number of operations.
Next N line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than 109.

Output
For each operation 3,output a line representing the answer.
 
Sample Input
6
1 2
1 3
3
1 3
1 4
3
 
Sample Output
3

4

//用multiset储存

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <string>
using namespace std;

int main()
{
    int n;
    scanf("%d",&n);
    multiset <int> se;
    multiset <int>::iterator it=se.begin();
    se.clear();
    while(n--)
    {
        int a,b;
        scanf("%d",&a);
        if(a==1)
        {
            scanf("%d",&b);
            se.insert(b);
        }
        else if(a==2)
        {
            if(se.empty())
                continue;
            else
            {
                it=se.begin();
                se.erase(it);
            }
        }
        else if(a==3)
        {
            if(se.empty())
                printf("0\n");
            else
            {
                it=se.end();
                it--;
                printf("%d\n",(*it));
            }
        }
    }


    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5349

标签:

原文地址:http://blog.csdn.net/a73265/article/details/47313051

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!