码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5344

时间:2015-08-06 11:07:51      阅读:102      评论:0      收藏:0      [点我收藏+]

标签:

MZL‘s xor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 546    Accepted Submission(s): 365

Problem Description
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1≤i,j≤n)
The xor of an array B is defined as B1 xor B2...xor Bn
 
Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers:n,m,z,l
A1=0,Ai=(Ai?1?m+z) mod l
1≤m,z,l≤5?105,n=5?105
 
Output
For every test.print the answer.
 
Sample Input
2
3 5 5 7
6 8 8 9
 
Sample Output
14

16

#include <stdio.h>

__int64 a[1000000];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,z,l;
        a[0]=0;
        scanf("%d%d%d%d",&n,&m,&z,&l);
        for(int i=1;i<n;i++)
        {
            a[i]=(a[i-1]*m+z)%l;  //  注意溢出
            a[0]^=a[i];
        }
        printf("%I64d\n",a[0]*2);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5344

标签:

原文地址:http://blog.csdn.net/a73265/article/details/47312969

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!