码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2717 && poj 3278 Catch That Cow

时间:2015-08-06 13:20:10      阅读:105      评论:0      收藏:0      [点我收藏+]

标签:

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9339    Accepted Submission(s): 2925


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
5 17
 

Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 

Source

USACO 2007 Open Silver 

bfs注意注释的几个地方,坑哭我了,,,只怪自己太菜

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int vis[110000];
int n,k;
struct node{
	int val,d;
}s,num;

int bfs(){
	memset(vis,0,sizeof(vis));
	queue <node> Q;
	while(!Q.empty()) Q.pop();
	s.val=n; s.d=0;
	vis[n]=1;
	Q.push(s);
	while(!Q.empty()){
		s=Q.front();
		Q.pop();
		for(int i=0;i<3;i++){
			if(i==0) num.val=s.val+1;
			if(i==1) num.val=s.val-1;
			if(i==2) num.val=s.val*2;
			num.d=s.d+1;
			if(num.val==k) return num.d;
			if(num.val<0 || num.val>110000)//原来写的num.val>k,wa了20多次,草,fuck,,, 
				continue;
			//if(num.val>=0&&!vis[num.val]&&num.val<100000){//这样写num.val大于110000是,vis数组就会溢出 
			if(!vis[num.val]){ 
				vis[num.val]=1;
				Q.push(num);
			}
 		}
	}
	return -1;	
}
int main(){
	while(scanf("%d%d",&n,&k)!=EOF){
		if(n>k) printf("%d\n",n-k);
		else if(n==k) printf("0\n");
		else 
			printf("%d\n",bfs());
	}
	return 0;
}


hdu 2717 && poj 3278 Catch That Cow

标签:

原文地址:http://blog.csdn.net/ling_du/article/details/47314035

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!