码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3278 Catch That Cow

时间:2015-08-06 13:25:00      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:

Catch That Cow

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 56   Accepted Submission(s) : 20
Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
5 17
 

Sample Output
4
 

Source
PKU

 

思路:

       这道题是一维坐标上给出起点和终点,然后让你用两种(也可以说是三种)不同的方式进行移动,看话费的最少时间是多少(也可以说是最小的步数是多少)!需要注意的是步行可以左右移动,但是瞬移(也就是另一种移动方式只能往前走),然后你用这三种方式对一维坐标中的点进行广搜,最小用多少步能够到达终点!

      这道题与之前做的题不同之处就是,之前的是在二维平面上进行广搜(有不同的路径),找最短的路径,而这道题虽然只有一条路径可以走,但是题目又给了一个限制,也就是可以有不同的行走方式,可以一步进行跨越式的走,所以就这样增加了路径的个数,所以这道题其实也是让求最短的路径的!

     一般上我们做求最短的路径的问题,我们就用广搜的方法!

 具体代码如下:

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;
#define INF 0xfffffff
int n,m,ans;
int vis[100005];
struct node 
{
	int x;
	int time;
	friend bool operator < (node a,node b)
	{
		return a.time>b.time;
	}
}a,temp;

int judge()
{
	if(temp.x<0||temp.x>100000)	return 0;
	if(vis[temp.x]==1)	return 0;
	if(temp.time>=ans)	return 0;
	return 1;
}

void bfs()
{
	a.x=n;//将起点的值赋值给结构体a然后将结构体a放到对列中,来寻找它周围的点(前后和2倍的这三个点) 
	a.time=0;//刚开始时间是0! 
	priority_queue<node>q;//设一个优先队列,来将最短的时间放到对顶 
	q.push(a);//将数组a压到队列里面 
	memset(vis,0,sizeof(vis));//清空标记数组 
	vis[n]=1;//起点进行标记 
	while(!q.empty())//如果队列不为空,进行下面的操作,来找终点 
	{
	a=q.top();//因为下面要用到对顶元素,所以只有队列不为空的时候,下面的操作才有意义! 
	q.pop();//赋值过之后出队列,因为你之后找过它周围的数之后,它已经没用了,就出队列吧 
	for(int i=0;i<3;i++)//三种不同的方式来寻找终点 
	{
		if(i==0)	temp.x=a.x+1;
		if(i==1)	temp.x=a.x-1;
		if(i==2)	temp.x=a.x*2;
		temp.time=a.time+1;//每走一步,对应的时间要加一 
		if(judge())//判断这个点是否符合要求,如果符合,则判断是不是要找的点 
		{
			if(temp.x==m)//如果是要找的点要将到达这个点所用的时间输出 
			{
				ans=temp.time;
				return;
			}//如果不是最终的点,需要将这个点标记一下,并且放进对列,找它周围有没有终点,一直 
			vis[temp.x]=1;//循环,知道找到终点为止! 
			q.push(temp);
		}
	}
   }
} 

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
        ans=INF;
        if(n==m)//因为起点和终点重合的时候,起点之前被标记了,而(在bfs中)终点要求不能够被标记,所以 
        	{//所以要在进bfs之前进行判断是否起点和终点重合! 
        	  printf("0\n");
        	  continue;
            }
		bfs();//调用dfs求最短时间(也就是最短路径)! 
		printf("%d\n",ans);
	}
	return 0;
}


 

 

 

版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 3278 Catch That Cow

标签:

原文地址:http://blog.csdn.net/dxx_111/article/details/47313709

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!