码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1426 Find The Multiple

时间:2015-08-06 13:26:26      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:dfs

poj 1426 的传送门

Language:
Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21735 Accepted: 8939 Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input

2
6
19
0
Sample Output

10
100100100100100100
111111111111111111

题目大意:给你一个数,让你找能够整除这个数的而且只含有0和1 的数,比如说
input :3;
output : 111;
可能有多个答案,只需要输出一个即可;
解题思路:用dfs搜索,只搜关于0和1 的数,详情见代码,,,,

上代码:

#include <iostream>

using namespace std;
bool fo;
void dfs(unsigned long long t, int k, int m)//unsigned一定要有,这是一个无符号字符类型,
{
    if(fo)//一定要有这句话,要不然会有很多个答案的。
        return ;
    if(t % m == 0)
    {
        cout<<t<<endl;
        fo=1;//标记
        return;
    }
    if(k == 19)//long long 最多有19位,
        return;
    dfs(t*10, k+1, m);//搜*10的
    dfs(t*10+1, k+1, m);//搜*10+1的
}
int main()
{
    int m;
    while(cin>>m,m)
    {
        fo=0;
        dfs(1, 0, m);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 1426 Find The Multiple

标签:dfs

原文地址:http://blog.csdn.net/qingshui23/article/details/47313563

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!