码迷,mamicode.com
首页 > 其他好文 > 详细

Ignatius and the Princess III

时间:2015-08-06 15:06:28      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15659    Accepted Submission(s): 11038


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627
 

Author
Ignatius.L
完全背包问题。把总和的那个数n看作是背包总容量。材料有1,2……n,这些材料向背包填充。最大价值对应的是最多方案。
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
   int n,i,j,a[150],dp[150];
   while(scanf("%d",&n)!=EOF)
   {
       memset(dp,0,sizeof(dp));
       dp[0]=1;
      for(i=1;i<=n;i++)
          a[i]=i;//材料容量
      for(i=1;i<=n;i++)
      {
          for(j=a[i];j<=n;j++)
          {
              dp[j]+=dp[j-a[i]];
          }
      }
      cout<<dp[n]<<endl;
   }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Ignatius and the Princess III

标签:

原文地址:http://blog.csdn.net/zuguodexiaoguoabc/article/details/47316249

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!