码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 题目2140 K-th Number(划分树)

时间:2015-08-06 18:22:06      阅读:119      评论:0      收藏:0      [点我收藏+]

标签:

K-th Number
Time Limit: 20000MS   Memory Limit: 65536K
Total Submissions: 42155   Accepted: 13855
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?"
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion

ac代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int tree[30][100100],sorted[100010],toleft[30][100010];
int cmp(const void *a,const void *b)
{
	return *(int *)a-*(int *)b;
}
void build(int l,int r,int dep)
{
	if(l==r)
	{
		return;
	}
	int mid=(l+r)>>1;
	int same=mid-l+1;
	int i;
	for(i=l;i<=r;i++)
		if(tree[dep][i]<sorted[mid])
			same--;
	int lpos=l;
	int rpos=mid+1;
	for(i=l;i<=r;i++)
	{
		if(tree[dep][i]<sorted[mid])
		{
			tree[dep+1][lpos++]=tree[dep][i];
		}
		else
			if(tree[dep][i]==sorted[mid]&&same>0)
			{
				tree[dep+1][lpos++]=tree[dep][i];
				same--;
			}
			else
				tree[dep+1][rpos++]=tree[dep][i];
			toleft[dep][i]=toleft[dep][l-1]+lpos-l;//1 l傻傻分不清楚
	}
	build(l,mid,dep+1);//又是1 l傻傻分不清楚
	build(mid+1,r,dep+1);
}
int query(int L,int R,int l,int r,int dep,int k)
{
	if(l==r)
	{
		return tree[dep][l];
	}
	int mid=(L+R)>>1;
	int cnt=toleft[dep][r]-toleft[dep][l-1];
	if(cnt>=k)
	{
		int newl=L+toleft[dep][l-1]-toleft[dep][L-1];
		int newr=newl+cnt-1;
		return query(L,mid,newl,newr,dep+1,k);
	}
	else
	{
		int newr=r+toleft[dep][R]-toleft[dep][r];
		int newl=newr-(r-l-cnt);
		return query(mid+1,R,newl,newr,dep+1,k-cnt);
	}
}
int main()
{
	int n,m;
//	while(scanf("%d%d",&n,&m)!=EOF)
//	{
		int i;
		scanf("%d%d",&n,&m);
		memset(tree,0,sizeof(tree));
		for(i=1;i<=n;i++)
		{
			scanf("%d",&tree[0][i]);
			sorted[i]=tree[0][i];
		}
		qsort(sorted+1,n,sizeof(sorted[1]),cmp);
		build(1,n,0);
		while(m--)
		{
			int a,b,k;
			scanf("%d%d%d",&a,&b,&k);
			int ans=query(1,n,a,b,0,k);
			printf("%d\n",ans);
		}
//	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 题目2140 K-th Number(划分树)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/47320297

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!