码迷,mamicode.com
首页 > 其他好文 > 详细

Myacm Triangles

时间:2014-05-04 09:37:36      阅读:286      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   java   

 Myacm Triangles

Source file: triangle.{ccppjavapas}
Input file: triangle.in
Output file: triangle.out
bubuko.com,布布扣

There has been considerable archeological work on the ancient Myacm culture. Many artifacts have been found in what have been called power fields: a fairly small area, less than 100 meters square where there are from four to fifteen tall monuments with crystals on top. Such an area is mapped out above. Most of the artifacts discovered have come from inside a triangular area between just three of the monuments, now called the power triangle. After considerable analysis archeologists agree how this triangle is selected from all the triangles with three monuments as vertices: it is the triangle with the largest possible area that does not contain any other monuments inside the triangle or on an edge of the triangle. Each field contains only one such triangle.

Archeological teams are continuing to find more power fields. They would like to automate the task of locating the power triangles in power fields. Write a program that takes the positions of the monuments in any number of power fields as input and determines the power triangle for each power field.

A useful formula: the area of a triangle with vertices (x1y1), (x2y2), and (x3y3) is the absolute value of

0.5 × [(y3 - y1)(x2 - x1- (y2 - y1)(x3 - x1)].

For each power field there are several lines of data. The first line is the number of monuments: at least 4, and at most 15. For each monument there is a data line that starts with a one character label for the monument and is followed by the coordinates of the monument, which are nonnegative integers less than 100. The first label is A, and the next is B, and so on.

There is at least one such power field described. The end of input is indicated by a 0 for the number of monuments. The first sample data below corresponds to the diagram in the problem.

For each power field there is one line of output. It contains the three labels of the vertices of the power triangle, listed in increasing alphabetical order, with no spaces.

Example input:

6
A 1 0
B 4 0
C 0 3
D 1 3
E 4 4
F 0 6
4
A 0 0
B 1 0
C 99 0
D 99 99
0

Example output:

BEF
BCD

解决方案:由于数据较小,可直接暴力,用上面积公式area=fabs(0.5 × [(y3 - y1)(x2 - x1- (y2 - y1)(x3 - x1)]);

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
struct node{
   double x,y;
   char c;
}point[16];
double getarea(double x0,double y0,double x1,double y1,double x2,double y2);
bool exitxpoint(node a,node b,node c,node d,double *area)
{
    double s=getarea(a.x,a.y,b.x,b.y,c.x,c.y);
    *area=s;
    double s1=getarea(a.x,a.y,b.x,b.y,d.x,d.y);
    double s2=getarea(a.x,a.y,d.x,d.y,c.x,c.y);
    double s3=getarea(d.x,d.y,b.x,b.y,c.x,c.y);
    if(fabs(s-s1-s2-s3)==0.0) return true;
    return false;
}
double getarea(double x1,double y1,double x2,double y2,double x3,double y3)
{
    return fabs((y3-y1)*(x2-x1)-(y2-y1)*(x3-x1));
}
int main()
{
    int n;
    char aa,bb,cc;
    while(~scanf("%d",&n)&&n){
        for(int i=0;i<n;i++)
        {
            cin>>point[i].c>>point[i].x>>point[i].y;
        }
        double area,Max=0.0;
        for(int i=0;i<n-2;i++)
            for(int j=i+1;j<n-1;j++)
            for(int k=j+1;k<n;k++){
                    int s=0;
                    for(s=0;s<n;s++)
                    {  
                        if(s!=i&&s!=j&&s!=k)
                        {
                            if(exitxpoint(point[i],point[j],point[k],point[s],&area))
                            {
                              break;

                            }
                        }
                    }
                    if(area>Max&&s==n){aa=point[i].c;bb=point[j].c;cc=point[k].c;Max=area;}

            }
            cout<<aa<<bb<<cc<<endl;

    }
    return 0;
}

Myacm Triangles,布布扣,bubuko.com

Myacm Triangles

标签:des   style   blog   class   code   java   

原文地址:http://blog.csdn.net/u012870383/article/details/24932437

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!