码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 1711 Number Sequence KMP字符串匹配

时间:2015-08-06 22:18:15      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:

HDU - 1711
Time Limit: 5000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u

 Status

Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 
 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 
 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 
 

Sample Input

2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output

6 -1
 第一类型代码:
/*
Problem : 1711 ( Number Sequence )     Judge Status : Accepted
RunId : 14382956    Language : G++    Author : 24862486
Code Render Status : Rendered By HDOJ G++ Code Render Version 0.01 Beta
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
const int MAXN = 10000 + 5;
const int MAXM = 1000000 + 5;
int T, N, M, a[MAXM], b[MAXN], nexts[MAXN];


void Get_Next() {
    int i = 0, j = -1;
    nexts[0] = -1;
    while(i < M - 1) {
        if(j == -1 || b[j] == b[i]) {
            j ++;
            i ++;
            if(b[j] == b[i]) {
                nexts[i] = nexts[j];
            } else {
                nexts[i] = j;
            }
        } else {
            j = nexts[j];
        }
    }
}


int Get_KMP() {
    int i = 0, j = 0;
    while(i < N && j < M) {
        if(j == -1 || a[i] == b[j]) {
            i ++;
            j ++;
        } else {
            j = nexts[j];//失配匹配
        }
    }
    if(j == M) {
        return i - j + 1;
    }
    return  -1;
}


int main() {
    scanf("%d", &T);
    while(T --) {
        scanf("%d %d", &N, &M);
        for(int i = 0; i < N; i ++) {
            scanf("%d", &a[i]);
        }
        for(int i = 0; i < M; i ++) {
            scanf("%d", &b[i]);
        }
        Get_Next();
        int cnt = Get_KMP();
        printf("%d\n", cnt);
    }
    return 0;
}

第二中类型:效率较低,但是代码简单,便于记忆以及理解
/*
Problem : 1711 ( Number Sequence )     Judge Status : Accepted
RunId : 14382956    Language : G++    Author : 24862486
Code Render Status : Rendered By HDOJ G++ Code Render Version 0.01 Beta
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
const int MAXN = 10000 + 5;
const int MAXM = 1000000 + 5;
int T, N, M, a[MAXM], b[MAXN], nexts[MAXN];


void Get_Next() {
    int i = 0, j = -1;
    nexts[0] = -1;
    while(i < M) {
        if(j == -1 || b[j] == b[i]) {
            nexts[++ i] = ++ j;
        } else {
            j = nexts[j];
        }
    }
}


int Get_KMP() {
    int i = 0, j = 0;
    while(i < N && j < M) {
        if(j == -1 || a[i] == b[j]) {
            i ++;
            j ++;
        } else {
            j = nexts[j];//失配匹配
        }
    }
    if(j == M) {
        return i - j + 1;
    }
    return  -1;
}


int main() {
    scanf("%d", &T);
    while(T --) {
        scanf("%d %d", &N, &M);
        for(int i = 0; i < N; i ++) {
            scanf("%d", &a[i]);
        }
        for(int i = 0; i < M; i ++) {
            scanf("%d", &b[i]);
        }
        Get_Next();
        int cnt = Get_KMP();
        printf("%d\n", cnt);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU - 1711 Number Sequence KMP字符串匹配

标签:

原文地址:http://blog.csdn.net/qq_18661257/article/details/47323835

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!