码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ题目4417 Super Mario(划分树求区间比k小的个数+二分)

时间:2015-08-06 22:20:43      阅读:113      评论:0      收藏:0      [点我收藏+]

标签:

Super Mario

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3313    Accepted Submission(s): 1548


Problem Description
Mario is world-famous plumber. His “burly” figure and amazing jumping ability reminded in our memory. Now the poor princess is in trouble again and Mario needs to save his lover. We regard the road to the boss’s castle as a line (the length is n), on every integer point i there is a brick on height hi. Now the question is how many bricks in [L, R] Mario can hit if the maximal height he can jump is H.
 

Input
The first line follows an integer T, the number of test data.
For each test data:
The first line contains two integers n, m (1 <= n <=10^5, 1 <= m <= 10^5), n is the length of the road, m is the number of queries.
Next line contains n integers, the height of each brick, the range is [0, 1000000000].
Next m lines, each line contains three integers L, R,H.( 0 <= L <= R < n 0 <= H <= 1000000000.)
 

Output
For each case, output "Case X: " (X is the case number starting from 1) followed by m lines, each line contains an integer. The ith integer is the number of bricks Mario can hit for the ith query.
 

Sample Input
1 10 10 0 5 2 7 5 4 3 8 7 7 2 8 6 3 5 0 1 3 1 1 9 4 0 1 0 3 5 5 5 5 1 4 6 3 1 5 7 5 7 3
 

Sample Output
Case 1: 4 0 0 3 1 2 0 1 5 1
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  5363 5362 5361 5360 5359 
 
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>   
int tree[30][100100],toleft[30][100100];  
int sorted[100100];  
int cmp(const void *a,const void *b)  
{  
    return *(int *)a-*(int *)b;  
}  
void build(int l,int r,int dep)  
{  
    if(l==r)  
        return;  
    int mid=(l+r)>>1;  
    int same=mid-l+1;  
    int i;  
    int lpos=l;  
    int rpos=mid+1;  
    for(i=l;i<=r;i++)  
    {  
        if(tree[dep][i]<sorted[mid])  
            same--;  
    }  
    for(i=l;i<=r;i++)  
    {  
        if(tree[dep][i]<sorted[mid])  
        {  
            tree[dep+1][lpos++]=tree[dep][i];  
        }  
        else  
            if(tree[dep][i]==sorted[mid]&&same>0)  
            {  
                tree[dep+1][lpos++]=tree[dep][i];  
                same--;  
            }  
            else  
                tree[dep+1][rpos++]=tree[dep][i];  
            toleft[dep][i]=toleft[dep][l-1]+lpos-l;  
    }  
    build(l,mid,dep+1);  
    build(mid+1,r,dep+1);  
}  
int query(int L,int R,int l,int r,int dep,int k)  
{  
    if(l==r)  
    {  
        return tree[dep][l];  
    }  
    int mid=(L+R)>>1;  
    int cnt=toleft[dep][r]-toleft[dep][l-1];  
    if(cnt>=k)  
    {  
        int newl=L+toleft[dep][l-1]-toleft[dep][L-1];  
        int newr=newl+cnt-1;  
        return query(L,mid,newl,newr,dep+1,k);  
    }  
    else  
    {  
        int newr=r+toleft[dep][R]-toleft[dep][r];  
        int newl=newr-(r-l-cnt);  
        return query(mid+1,R,newl,newr,dep+1,k-cnt);  
    }  
}
int main()
{
	int t,c=0;
	scanf("%d",&t);
	while(t--)
	{
		int n,m;
		while(scanf("%d%d",&n,&m)!=EOF)
		{
			int i;
			for(i=1;i<=n;i++)
			{
				scanf("%d",&tree[0][i]);
				sorted[i]=tree[0][i];
			}
			qsort(sorted+1,n,sizeof(sorted[1]),cmp);
			build(1,n,0);
			printf("Case %d:\n",++c);
			while(m--)
			{
				int a,b,h;
				scanf("%d%d%d",&a,&b,&h);
				a++;
				b++;
				int l=1,r=(b-a)+1;
				int ans=0;
				while(l<=r)
				{
					int mid=(l+r)>>1;
					int temp=query(1,n,a,b,0,mid);
					if(temp<=h)
					{
						ans=mid;
						l=mid+1;
					}
					else
						r=mid-1;
				}
				printf("%d\n",ans);
			}
		}
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDOJ题目4417 Super Mario(划分树求区间比k小的个数+二分)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/47323747

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!