码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1050&&nyoj220 Moving Tables(贪心)

时间:2015-08-06 22:37:40      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:hdu1050   hdu 1050   nyoj220   nyoj 220   

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24372    Accepted Submission(s): 8071


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

技术分享


The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

技术分享


For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
10 20 30
 

Source
 

Recommend
We have carefully selected several similar problems for you:  1052 1789 1045 1053 1800 
 

Statistic | Submit | Discuss | Note

很经典贪心。记得以前考试的时候见到了好多遍 可是每次都不会做。。

可惜现在不是以前了 哈哈、、、

类似于拦截导弹,然而这道和拦截导弹的不同点在于,一个走廊有两个房间,如果一个房间在用走廊,对面的房间就不能用走廊。

稍微优化一下就好啦。。把所有的奇数房间都+1,不影响结果。。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
	int a,b;
}c[205];
int vis[205];
bool cmp(node x,node y)
{
	if(x.a<y.a) return true;
	if(x.a==y.a&&x.b<y.b) return true;
	return false;
}
int main()
{
	int ncase,n;
	scanf("%d",&ncase);
	while(ncase--)
	{
		scanf("%d",&n);
		memset(vis,0,sizeof(vis));
		for(int i=0;i<n;i++)
		{
			int x,y,temp;
			scanf("%d %d",&x,&y);
			if(x%2)
			x++;
			if(y%2)
			y++;
			if(x>y)
			temp=x,x=y,y=temp;//小心 小心、、
			c[i].a=x,c[i].b=y;
		}
		sort(c,c+n,cmp);
		int count=0,mark;
		for(int i=0;i<n;i++)//类似于拦截导弹。。就是最小拦截次数那个
		{
			if(!vis[i])
			{
				count++,mark=c[i].b;
				for(int j=i+1;j<n;j++)
				if(!vis[j]&&c[j].a>mark)
				vis[j]=1,mark=c[j].b;
			}
		}
		printf("%d\n",count*10);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu1050&&nyoj220 Moving Tables(贪心)

标签:hdu1050   hdu 1050   nyoj220   nyoj 220   

原文地址:http://blog.csdn.net/su20145104009/article/details/47322141

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!