码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1156 Palindrome

时间:2014-07-10 19:53:48      阅读:245      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   strong   

Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 51631   Accepted: 17768

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2


题意:

给你一串字符串,让你求最少加入几个字符,才能使得这个字符串是个回文串。

分析:

设a[i]是这个字符串,b[i]是这个字符串的逆序串。

那么a[i],b[i]的最长公共子序列就是所求的字符串里拥有的最大的回文串。

然后用总串长度减去最大的回文串长度即为所求。


求最长公共子序列:

1).递归式写成:


bubuko.com,布布扣


2).回溯输出最长公共子序列过程:

bubuko.com,布布扣

 

#include<stdio.h>
#include<iostream>
using namespace std;
#define Max 5001

char a[Max],b[Max];
short int dp[Max][Max];    // 用short int数组

int max(int x,int y)
{
	return (x>y?x:y);
}

int main ()
{
	
	int n,i,j;
	scanf("%d",&n);
	getchar();
	for(i=1,j=n;i<=n,j>=1;i++,j--)
	{
		scanf("%c",&a[i]);
		b[j]=a[i];
	}
	
	for(i=0;i<=n;i++)  
    {  
        dp[i][0]=0;  
        dp[0][i]=0;  
    }  
	
	for(i=1;i<=n;i++)    // 求最长公共子序列
	{
		for(j=1;j<=n;j++)
		{
			if(a[i]==b[j]) dp[i][j]=dp[i-1][j-1]+1;
			else           dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
		}
		
	}
	printf("%d\n",n-dp[n][n]);   // 总串长度减去最长公共子序列(最大的回文串)长度
	return 0;
}




poj 1156 Palindrome,布布扣,bubuko.com

poj 1156 Palindrome

标签:des   style   blog   http   color   strong   

原文地址:http://blog.csdn.net/fyxz1314/article/details/37594407

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!