码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3278: Catch That Cow

时间:2014-07-10 17:30:26      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:poj   bfs   

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 44613   Accepted: 13946

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4


题意:有一个农民和一头牛,他们在一个数轴上,牛在k位置保持不动,农户开始时在n位置。设农户当前在M位置,每次移动时有三种选择:1.移动到M-1;2.移动到M+1位置;3.移动到M*2的位置。问最少移动多少次可以移动到牛所在的位置。所以可以用BFS来搜索这三个状态,直到搜索到牛所在的位置。


#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;

const int N = 200100;
int n, k;
struct node
{
    int x, step;
};
queue<node> q;
int vist[N];

void bfs()
{  
    int cow, ans;
    while(!q.empty())
    {
        node tmp = q.front();
        q.pop();
        cow = tmp.x;
        ans = tmp.step;
        if(cow == k)
        {
            printf("%d\n",ans);
            return ;
        }
        if(cow >= 1 && !vist[cow - 1]) //要保证减1后有意义,所以要cow >= 1    减一的情况
        {
            node temp;
            vist[cow - 1] = 1;
            temp.x = cow - 1;
            temp.step = ans + 1;
            q.push(temp);
        }
        if(cow <= k && !vist[cow + 1]) //加1的情况
        {
            node temp;
            vist[cow + 1] = 1;
            temp.x = cow + 1;
            temp.step = ans + 1;
            q.push(temp);
        }
        if(cow <= k && !vist[cow * 2]) //乘二的情况
        {
            node temp;
            vist[cow * 2] = 1;
            temp.x = 2 * cow;
            temp.step = ans + 1;
            q.push(temp);
        }
    }
}

int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        while(!q.empty()) q.pop();
        memset(vist,0,sizeof(vist));
        vist[n] = 1;
        node t;
        t.x = n, t.step = 0;
        q.push(t);
        bfs();
    }
    return 0;
}



POJ 3278: Catch That Cow,布布扣,bubuko.com

POJ 3278: Catch That Cow

标签:poj   bfs   

原文地址:http://blog.csdn.net/u013487051/article/details/37594177

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!