码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5363 Key Set(快速幂取余)

时间:2015-08-07 11:10:19      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:

Key Set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 362    Accepted Submission(s): 238


Problem Description
soda has a set S with n integers {1,2,,n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.
 

Input
There are multiple test cases. The first line of input contains an integer T (1T105), indicating the number of test cases. For each test case:

The first line contains an integer n (1n109), the number of integers in the set.
 

Output
For each test case, output the number of key sets modulo 1000000007.
 

Sample Input
4 1 2 3 4
 

Sample Output
0 1 3 7
 

Source



题目链接:点击打开链接


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
__int64 f( __int64 n,__int64 m,__int64 s)
{
    __int64 t;
    n=n%s;
    t=1;
    if(n==0)return 0;
    while(m)
    {
        if(m%2==1)
        {
            t*=n;
            t%=s;
        }
        n*=n;
        n%=s;
        m/=2;
    }
    return t;
}
int main()
{
    __int64 n,i,x;
    scanf("%I64d",&n);
    for(i=1;i<=n;i++)
    {
        scanf("%I64d",&x);
        if(x==1)
        {
            printf("0\n");
            continue;
        }

       __int64 t=f(2,x-1,1000000007);
       printf("%I64d\n",t-1);
    }

}


 

版权声明:本文为博主原创文章,如有特殊需要请与博主联系 QQ : 793977586。

HDU 5363 Key Set(快速幂取余)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/47335595

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!