码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1086:You can Solve a Geometry Problem too

时间:2014-07-10 19:30:48      阅读:256      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   java   color   strong   

You can Solve a Geometry Problem too

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6997    Accepted Submission(s): 3385


Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point. 
 

Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the number of intersections, and one line one case.
 

Sample Input
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0
 

Sample Output
1 3
这是一道几何题, 就是在于你是否会判断两条直线直接是否有交点的方法。
剩下就很容易了。
判断AB和CD两线段是否有交点:
同时满足两个条件:(‘x‘表示叉积)
1.C点D点分别在AB的两侧.(向量(ABxAC)*(ABxAD)<=0)
2.A点和B点分别在CD两侧.(向量(CDxCA)*(CDxCB)<=0)
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>

using namespace std;

struct Node
{
    double x1, y1, x2, y2;
}point[105];
int n;

double work(double x1, double y1, double x2, double y2)
{
    return x1 * y2 - x2 * y1;
}

bool judge(int i, int j)
{
    double a = work(point[i].x1 - point[j].x1, point[i].y1 - point[j].y1, point[i].x1 - point[i].x2, point[i].y1 - point[i].y2);
    double b = work(point[i].x1 - point[i].x2, point[i].y1 - point[i].y2, point[i].x1 - point[j].x2, point[i].y1 - point[j].y2);
    a = a * b;
    double c = work(point[j].x1 - point[i].x1, point[j].y1 - point[i].y1, point[j].x1 - point[j].x2, point[j].y1 - point[j].y2);
    double d = work(point[j].x1 - point[j].x2, point[j].y1 - point[j].y2, point[j].x1 - point[i].x2, point[j].y1 - point[i].y2);
    c = c * d;
    if(a >= 0 && c >= 0)
        return true;
    return false;
}

int main()
{
    while(cin >> n, n){
        for(int i = 0; i < n; i++)
            cin >> point[i].x1 >> point[i].y1 >> point[i].x2 >> point[i].y2;
        int count = 0;
        for(int i = 0; i < n; i++)
        {
            for(int j = i + 1; j < n; j++)
                if(judge(i, j))
                    count++;
        }
        cout << count << endl;
 }
    return 0;
}



HDU 1086:You can Solve a Geometry Problem too,布布扣,bubuko.com

HDU 1086:You can Solve a Geometry Problem too

标签:des   style   http   java   color   strong   

原文地址:http://blog.csdn.net/u013487051/article/details/37591587

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!