码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2533 Longest Ordered Subsequence

时间:2014-07-10 20:27:45      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   strong   width   os   

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 31787   Accepted: 13903

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4


题意:求最长子序列的长度

#include<stdio.h>
int main ()
{
  int n,i,j;
  int t=0;
  int a[1006],dp[1006];
  scanf("%d",&n);
  for(i=0;i<n;i++)
  {
   scanf("%d",&a[i]);
      dp[i]=1;
  }

  for(i=0;i<n;i++)
  {
    for(j=0;j<i;j++)
	{
	  if(a[i]>a[j] && dp[i]<dp[j]+1)
		  dp[i]=dp[j]+1;
	}
  }

  for(i=0;i<n;i++)
  {
    if(t<dp[i])
		t=dp[i];
  }
  printf("%d\n",t);
  return 0;
}



poj 2533 Longest Ordered Subsequence,布布扣,bubuko.com

poj 2533 Longest Ordered Subsequence

标签:des   style   color   strong   width   os   

原文地址:http://blog.csdn.net/fyxz1314/article/details/37591417

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!