码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5363 Key Set

时间:2015-08-07 14:51:56      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:

hdu 5363 的传送门

Problem Description

soda has a set S with n integers {1,2,…,n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:

The first line contains an integer n (1≤n≤109), the number of integers in the set.

Output

For each test case, output the number of key sets modulo 1000000007.

Sample Input

4
1
2
3
4

Sample Output

0
1
3
7

题目大意:给你一个数m,然后有m个数,这个数有多少个和是偶数的集合,e:给你3,集合有{1},{1,2},{1,3},
{1,2,3},{2},{2,3},{3}

然而和是偶数的只有{1,2},{1,3},{2,3};

解题思路:推出公式; ans=2 ^ (m-1) - 1;

下面上代码:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int mod = 1000000007;
typedef long long LL;
LL quick(int m)
{
    m-=1;
    LL ans=1;
    LL tmp=2;
    while(m)
    {
        if(m&1)
        {
            ans=ans*tmp%mod;
            m--;
        }
        tmp=(tmp*tmp)%mod;
        m>>=1;
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int m;
        scanf("%d",&m);
        printf("%lld\n",quick(m)-1);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 5363 Key Set

标签:

原文地址:http://blog.csdn.net/qingshui23/article/details/47337921

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!