码迷,mamicode.com
首页 > 其他好文 > 详细

uva 动态规划 437 The Tower of Babylon

时间:2015-08-07 14:52:28      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:acm   uva   

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions 技术分享 . A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn‘t be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input and Output

The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values 技术分享 , 技术分享 and 技术分享 .

Input is terminated by a value of zero (0) for n.

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Casecase: maximum height =height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

 Status


//#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<cmath>
#include<stdlib.h>
#include<map>
#include<set>
#include<time.h>
#include<vector>
#include<queue>
#include<string>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define eps 1e-8
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
typedef pair<int , int> pii;
#define maxn 35

int n;
LL d[maxn][3];
int vis[maxn][3];
struct block
{
    LL h[3];
} B[maxn];

bool judge(int t1, int x1, int t2, int x2)
{
    LL a[2], b[2];
    int cn1 = 0, cn2 = 0;
    for(int i = 0; i < 3; i++)
    {
        if(i != x1)
        a[cn1++] = B[t1].h[i];
        if(i != x2)
        b[cn2++] = B[t2].h[i];
    }
    for(int i = 0; i < 2; i++)
    {
        if(a[i] >= b[i])
        return false;
    }
    return true;
}

int dfs(int t, int x)
{
    if(vis[t][x]) return d[t][x];
    vis[t][x] = 1;
    LL &res = d[t][x];

    for(int i = 1; i <= n; i++)
        {
            for(int j = 0; j < 3; j++)
            {
                if(judge(t, x, i, j))
                    {
                        res = max(res, dfs(i, j) + B[t].h[x]);
                    }
            }
        }
    return res;
}

int main()
{
    int kase = 0;
    while(~scanf("%d", &n) && n)
    {
        memset(vis, 0, sizeof vis);
        for(int i = 1; i <= n; i++)
        {
            scanf("%I64d%I64d%I64d", &B[i].h[0], &B[i].h[1], &B[i].h[2]);
            sort(B[i].h , B[i].h + 3);
            for(int k = 0; k < 3; k++)
            {
                d[i][k] = B[i].h[k];
            }
        }
        long long ans = 0;
        for(int i = 1; i <= n; i++)
        {
            for(int j = 0; j < 3; j++)
            {
                if(!vis[i][j])
                {
                    d[i][j] = dfs(i, j);
                    ans = max(ans, d[i][j]);
                }
            }
        }
        printf("Case %d: maximum height = %lld\n", ++kase, ans);
    }
    return 0;
}

/*

1
10 10 10

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
*/


版权声明:本文为博主原创文章,未经博主允许不得转载。

uva 动态规划 437 The Tower of Babylon

标签:acm   uva   

原文地址:http://blog.csdn.net/dojintian/article/details/47337649

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!