码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-1134-Game of Connections【卡特兰数】

时间:2015-08-07 19:51:10      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:

Game of Connections

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3599 Accepted Submission(s): 2072


Problem Description
This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, ... , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another. And, no two segments are allowed to intersect.

It‘s still a simple game, isn‘t it? But after you‘ve written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?

Input
Each line of the input file will be a single positive number n, except the last line, which is a number -1. You may assume that 1 <= n <= 100.

Output
For each n, print in a single line the number of ways to connect the 2n numbers into pairs.

Sample Input
2 3 -1

Sample Output
2 5

Source

Recommend
Eddy | We have carefully selected several similar problems for you: 1133 1130 1131 2067 1267


#include<stdio.h>
#include<string.h>
const int maxn=200;
int catalan[101][200];
int temp[200];
void make(){
	memset(catalan,0,sizeof(catalan));
	catalan[1][0]=1;
	int i,j,res;
	for(i=2;i<=100;++i){
		int mod=4*i-2;
		for(j=0;j<maxn;++j){
			catalan[i][j]+=catalan[i-1][j]*mod;
			if(catalan[i][j]>=10){
				catalan[i][j+1]=catalan[i][j]/10;
				catalan[i][j]%=10;
			}
		}
		memset(temp,0,sizeof(temp));
		mod=i+1;
		res=0;
		for(j=maxn-1;j>=0;--j){
			temp[j]=(res*10+catalan[i][j])/mod;
			res=(res*10+catalan[i][j])%mod;
		}
		for(j=0;j<maxn;++j){
			catalan[i][j]=temp[j];
		}
	}
}
int main(){
	make();
	int n;
	while(~scanf("%d",&n),n!=-1){
		int i=maxn-1;
		while(!catalan[n][i]) --i;
		while(i>=0){
			printf("%d",catalan[n][i--]);
		}
		printf("\n");
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj-1134-Game of Connections【卡特兰数】

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/47343403

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!