码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-1023-Train Problem II【卡特兰数】

时间:2015-08-07 19:56:57      阅读:116      评论:0      收藏:0      [点我收藏+]

标签:

Train Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6852 Accepted Submission(s): 3708


Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

Output
For each test case, you should output how many ways that all the trains can get out of the railway.

Sample Input
1 2 3 10

Sample Output
1 2 5 16796
Hint
The result will be very large, so you may not process it by 32-bit integers.

Author
Ignatius.L

Recommend
We have carefully selected several similar problems for you: 1133 1130 1131 1134 2067


卡特兰数的递推公式为: h(n)=  h(n-1)*[ (4*n-2)/ (n+1)] 
#include<stdio.h>
#include<string.h>
const int MAXN=200;
int catalan[105][MAXN];
int temp[MAXN];
void create(){
	memset(catalan,0,sizeof(catalan));
	catalan[1][0] = 1;
	int i,j,res; 
	for(i = 2; i <= 100; ++i) {
		int mid = 4*i-2;
		for(j = 0;j < MAXN;++j){
		    catalan[i][j] += catalan[i-1][j] * mid;
		    if(catalan[i][j]>=10){
		    	catalan[i][j+1] += catalan[i][j]/10;
		    	catalan[i][j] = catalan[i][j]%10;
		    }
		}
		memset(temp,0,sizeof(temp));
		mid=i+1;
		res=0;
		for(j=MAXN-1;j>=0;--j){
			temp[j] = (res*10 + catalan[i][j])/mid;
			res = (10*res + catalan[i][j])%mid;
		}
		for(j=0; j<MAXN; ++j){
			catalan[i][j] = temp[j];
		}
	}
}
int main(){
	create();
	int n;
	while(~scanf("%d",&n)){
		int i=MAXN-1;
		while(!catalan[n][i]) --i;
		for(;i>=0;--i){
			printf("%d",catalan[n][i]);
		}
		printf("\n");
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj-1023-Train Problem II【卡特兰数】

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/47342733

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!